import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z0-9_\\.-]+)@([\\da-z\\.-]+)\\.([a-z\\.]{2,6})$";
final String string = "abc.com\n"
+ "abc.in\n"
+ "abc.pqr.com\n"
+ "abc.com/xyz\n"
+ "abc.com/xyz/pqr\n"
+ "no.matter.how-many.domain-name.com/anything\n"
+ "sruti@gmail.com\n"
+ "john@doe.com\n"
+ "a\n"
+ "a.\n"
+ "a..a\n"
+ "a./\n"
+ "a/\n"
+ "a/a.a\n\n"
+ "http://example.com\n"
+ "abc.com////\n"
+ "abc.com///xyz\n"
+ ".....likewise";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}