import re
regex = re.compile(r"^([a-z0-9_\.-]+)@([\da-z\.-]+)\.([a-z\.]{2,6})$")
test_str = ("abc.com\n"
"abc.in\n"
"abc.pqr.com\n"
"abc.com/xyz\n"
"abc.com/xyz/pqr\n"
"no.matter.how-many.domain-name.com/anything\n"
"sruti@gmail.com\n"
"john@doe.com\n"
"a\n"
"a.\n"
"a..a\n"
"a./\n"
"a/\n"
"a/a.a\n\n"
"http://example.com\n"
"abc.com////\n"
"abc.com///xyz\n"
".....likewise")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")