package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[[,\d\s ]*)11([,\d\s ]*\])`)
var str = `[11,12, 11] [10] [11] [19, 11]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}