$re = '/(\[[,\d\s ]*)11([,\d\s ]*\])/';
$str = '[11,12, 11] [10] [11] [19, 11]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);