const regex = /\d+\s*x\b(?:\([^()]*\)|[^()])*?(?=\d+x|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\s*x\\b(?:\\([^()]*\\)|[^()])*?(?=\\d+x|$)', 'gim')
const str = `10 x source 4 50° on booms (2 downstage left and right, 2 upstage left and right) 2x festoons (mentioned above) 4x 1kx Fresnel backlight in L712 4x SL 15/32 (3x L443, 4x R119) – all four of which are specifically focused specials 1x Edison bulb suspended from grid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}