re = /\d+\s*x\b(?:\([^()]*\)|[^()])*?(?=\d+x|$)/im
str = '10 x source 4 50° on booms (2 downstage left and right, 2 upstage left and right) 2x festoons (mentioned above) 4x 1kx Fresnel backlight in L712 4x SL 15/32 (3x L443, 4x R119) – all four of which are specifically focused specials 1x Edison bulb suspended from grid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end