using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)\b[^>]*?class=""myclass""(?:(?!</?\1\b).)+</\1>(*SKIP)(*F)|<a\b.*?</a>\s*";
string substitution = @"";
string input = @"<p>Hi Hello <a href=""#"">World</a></p>. This is <div class=""myclass"">testing <a href=""#"">content</a>. some more content</div>. One more <a href=""#""> Link </a>.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}