import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+)\\b[^>]*?class=\"myclass\"(?:(?!</?\\1\\b).)+</\\1>(*SKIP)(*F)|<a\\b.*?</a>\\s*";
final String string = "<p>Hi Hello <a href=\"#\">World</a></p>. This is <div class=\"myclass\">testing <a href=\"#\">content</a>. some more content</div>. One more <a href=\"#\"> Link </a>.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}