re = /\b\w+\[\s*(['"])(.+?)\1\s*\]/
str = 'someObject[\'propertyName\']
someObject["propertyName"]
someObject[ "propertyName" ]
someObject[ \'propertyName\' ]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end