import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&|((?:(?!&)[\\s\\S])+)";
final String string = "abc Ben & Jerry's foobar ssss sss sss &\n\n\n"
+ "sssss&sssss &\n\n"
+ "sssss&sssss &sssss\n"
+ "&sssss&\n"
+ "&&";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}