$re = '/&|((?:(?!&)[\s\S])+)/';
$str = 'abc Ben & Jerry\'s foobar ssss sss sss &
sssss&sssss &
sssss&sssss &sssss
&sssss&
&&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);