import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\(\\+?[0-9]{2}\\))?[ .-]?[0-9]{3}([ .-]?)[0-9]{3}\\1[0-9]{1,3}$";
final String string = "555333222\n"
+ "555 333 222\n"
+ "(11)555333222\n"
+ "(11)555 333 222\n"
+ "(+11)555333222";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}