re = /^(?:\(\+?[0-9]{2}\))?[ .-]?[0-9]{3}([ .-]?)[0-9]{3}\1[0-9]{1,3}$/m
str = '555333222
555 333 222
(11)555333222
(11)555 333 222
(+11)555333222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end