re = /(var\s+(\w[\w\-\_]*)\s*(?:=\s*(\d+|['"][\w\W]+['"]))?;?)/m
str = 'var stuff = 1;
var string = "dsa";
var lone;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end