# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((volume|part)|(^,)\s?(vol|pt)[^.]+?)/\1/gism;t' <<< "Should Match:
a) Any occurences of \"Volume\" OR \"Part\" (Case Insensitive);
b) Any occurence of \"vol\" or \"pt\" (CI) that does not have [[comma][space] before AND [period] after;
My volume 1
My name vol2.
My, volume 1
, pt. vol2.
, part.
, pt.
, pt
, vol
. pt.
// Should match below as there is no [period] after it
The Red Pill, Pt 2
, Pt 2"