# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((volume|part)|(^,)\s?(vol|pt)[^.]+?)"
test_str = ("Should Match: \n"
" a) Any occurences of \"Volume\" OR \"Part\" (Case Insensitive);\n"
" b) Any occurence of \"vol\" or \"pt\" (CI) that does not have [[comma][space] before AND [period] after;\n\n"
"My volume 1 \n"
"My name vol2.\n"
"My, volume 1 \n"
", pt. vol2.\n\n"
", part.\n"
", pt.\n"
", pt \n"
", vol\n"
". pt.\n\n"
"// Should match below as there is no [period] after it\n"
"The Red Pill, Pt 2\n"
", Pt 2")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.