using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,\s(?:vol|pt)\.(*SKIP)(*F)|(?:vol|pt|volume|part))";
string substitution = @"\1";
string input = @"Should Match:
a) Any occurences of ""Volume"" OR ""Part"" (Case Insensitive);
b) Any occurence of ""vol"" or ""pt"" (CI) that does not have [[comma][space] before AND [period] after;
My volume 1
My name vol2.
My, volume 1
, pt. vol2.
, part.
, pt.
, pt
, vol
. pt.
// Should match below as there is no [period] after it
The Red Pill, Pt 2
, Pt 2";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}