import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(,\\s(?:vol|pt)\\.(*SKIP)(*F)|(?:vol|pt|volume|part))";
final String string = "Should Match: \n"
+ " a) Any occurences of \"Volume\" OR \"Part\" (Case Insensitive);\n"
+ " b) Any occurence of \"vol\" or \"pt\" (CI) that does not have [[comma][space] before AND [period] after;\n\n"
+ "My volume 1 \n"
+ "My name vol2.\n"
+ "My, volume 1 \n"
+ ", pt. vol2.\n\n"
+ ", part.\n"
+ ", pt.\n"
+ ", pt \n"
+ ", vol\n"
+ ". pt.\n\n"
+ "// Should match below as there is no [period] after it\n"
+ "The Red Pill, Pt 2\n"
+ ", Pt 2";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}