const regex = new RegExp('^(?=.*\\bWASHER\\b)(?=.*\\bFLAT\\b)(?=.*\\b10MM\\b)(?=.*\\bSS\\b).*', 'gm')
const str = `4078. F00010 WASHER FLAT 20MM GALV
4078. F00010 WASHER FLAT 10MM SS
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}