$re = '/^(?=.*\bWASHER\b)(?=.*\bFLAT\b)(?=.*\b10MM\b)(?=.*\bSS\b).*/m';
$str = '4078. F00010 WASHER FLAT 20MM GALV
4078. F00010 WASHER FLAT 10MM SS
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);