import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"[^\\n]*\"(?!\\\\))|(//[^\\n]*$|/(?!\\\\)\\*[\\s\\S]*?\\*(?!\\\\)/)";
final String string = "#include <stdio.h>\n\n"
+ "int main(int argc, char** argv)\n"
+ "{\n"
+ " // this comment will be removed\n"
+ " if (argc > 1) {\n"
+ " printf(\"Too many arguments.\\n\"); // this too will be removed\n"
+ " return 1;\n"
+ " }\n"
+ " printf(\"Please vist http://this.will.not.be.removed.com\\n\");\n"
+ " printf(\"/* This will stay */\\n\");\n"
+ " printf(\"\\\"/* This will stay too */\\\"\\n\");\n"
+ " printf(\"//and so will this\\\\\");\n"
+ " // but not this\n"
+ " printf(\"just \\\"ano//ther\\\" test.\");\n"
+ " return 0;\n"
+ "}\n"
+ "/*\n"
+ " this shall disappear\n"
+ "*/\n"
+ "#include <string>\n"
+ "int main(int argc, char** argv)\n"
+ "{\n"
+ " string foo = \"\"/*remove that!**/;\n"
+ " // Remove /* this\n"
+ " int butNotThis = 42;\n"
+ " // But do */ remove this\n"
+ " int bar = 4 /*remove this*/* 3; // but don't remove that 3. */\n"
+ " return 0;//just a comment\n"
+ "}/*end of the file has been reached.*/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}