# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"[^\n]*\"(?!\\))|(//[^\n]*$|/(?!\\)\*[\s\S]*?\*(?!\\)/)"
test_str = ("#include <stdio.h>\n\n"
"int main(int argc, char** argv)\n"
"{\n"
" // this comment will be removed\n"
" if (argc > 1) {\n"
" printf(\"Too many arguments.\\n\"); // this too will be removed\n"
" return 1;\n"
" }\n"
" printf(\"Please vist http://this.will.not.be.removed.com\\n\");\n"
" printf(\"/* This will stay */\\n\");\n"
" printf(\"\\\"/* This will stay too */\\\"\\n\");\n"
" printf(\"//and so will this\\\\\");\n"
" // but not this\n"
" printf(\"just \\\"ano//ther\\\" test.\");\n"
" return 0;\n"
"}\n"
"/*\n"
" this shall disappear\n"
"*/\n"
"#include <string>\n"
"int main(int argc, char** argv)\n"
"{\n"
" string foo = \"\"/*remove that!**/;\n"
" // Remove /* this\n"
" int butNotThis = 42;\n"
" // But do */ remove this\n"
" int bar = 4 /*remove this*/* 3; // but don't remove that 3. */\n"
" return 0;//just a comment\n"
"}/*end of the file has been reached.*/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.