package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/.*?\/(.*?)\/(\d+)?.*$`)
var str = `/7/ipsum/dolor/etc
/2/not/17/ipsum/etc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}