$re = '/^\/.*?\/(.*?)\/(\d+)?.*$/m';
$str = '/7/ipsum/dolor/etc
/2/not/17/ipsum/etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);