package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?\d+(?:\.\d+)?$`)
var str = `22.86
22..43
-4.87
8
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}