$re = '/^-?\d+(?:\.\d+)?$/m';
$str = '22.86
22..43
-4.87
8
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);