using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<Title>[^_]*)_([^,]*),\s*([^.]*)";
string substitution = @"";
string input = @"Report on ATP Cycle_Doe, John.epub";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}