$re = '/(?<Title>[^_]*)_([^,]*),\s*([^.]*)/m';
$str = 'Report on ATP Cycle_Doe, John.epub';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;