const regex = /^\((?P<speciality>(?:[0-9x]+,?)+)(?=\))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\((?P<speciality>(?:[0-9x]+,?)+)(?=\\))', 'mg')
const str = `(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}