re = /^\((?P<speciality>(?:[0-9x]+,?)+)(?=\))/m
str = '(7)Which of the following is LEAST to be considered as a risk factor for esophageal cancer?;
(8,13)30 year old woman with amenorrhea, low serum estrogen and high serum LH/FSH, the most likely diagnosis is:
First trimester spontaneous abortion (before 20 wk) is most commonly due to:
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end