#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^no |^ *)logging .+(.[0-9]|: *[a-fA-F0-9]{4}).+$"
Local $sString = "logging trap notice" & @CRLF & _
"logging 10.29.9.20" & @CRLF & _
"logging 10.29.9.20 trap info" & @CRLF & _
"logging 10.92.9.20" & @CRLF & _
"logging 10.92.9.20 trap info" & @CRLF & _
"logging level audit mgmt notice" & @CRLF & _
"logging level cli commands notice" & @CRLF & _
"logging local notice"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")