import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^no |^ *)logging .+(.[0-9]|: *[a-fA-F0-9]{4}).+$";
final String string = "logging trap notice\n"
+ "logging 10.29.9.20\n"
+ "logging 10.29.9.20 trap info\n"
+ "logging 10.92.9.20\n"
+ "logging 10.92.9.20 trap info\n"
+ "logging level audit mgmt notice\n"
+ "logging level cli commands notice\n"
+ "logging local notice";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}