import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]+>([^<]+)<\\/[^>]+>";
final String string = "<SimpleData name=\"HDRNAME\">Uprr #43 Pan Am B #12</SimpleData>";
final String subst = "<name>$1</name>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}