const regex = /<[^>]+>([^<]+)<\/[^>]+>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]+>([^<]+)<\\\/[^>]+>', 'g')
const str = `<SimpleData name="HDRNAME">Uprr #43 Pan Am B #12</SimpleData>`;
const subst = `<name>$1</name>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);