package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w+.-]*@\w[\w-]*\.[\w-]*[0-9a-zA-Z.]+$`)
var str = `12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}