$re = '/^[\w+.-]*@\w[\w-]*\.[\w-]*[0-9a-zA-Z.]+$/m';
$str = '12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);