const regex = /^(?:db\.[a-zA-Z0-9]+\.[a-zA-Z0-9]+\()({(.|[\r\n])*})(?=\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:db\\.[a-zA-Z0-9]+\\.[a-zA-Z0-9]+\\()({(.|[\\r\\n])*})(?=\\))', '')
const str = `db.foobar.fooo({
})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}