re = /^(?:db\.[a-zA-Z0-9]+\.[a-zA-Z0-9]+\()({(.|[\r\n])*})(?=\))/
str = 'db.foobar.fooo({
})'
# Print the match result
str.match(re) do |match|
puts match.to_s
end