// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(http|https):\/\/").unwrap();
let string = "https://images.unsplash.com/photo-1441742917377-57f78ee0e582?q=80&fm=jpg&s=a79e8a2beba8b3a1ad251798a9024d8b
http://stackoverflow.com/questions/10625497/regex-to-check-if-http-or-https-exists-in-the-string
Http://thepaperwall.com/wallpaper.php?view=4d119619f49377f7aacc7efe564c3bf890b3c063
hTTp://thepaperwall.com/wallpapers/girls/big/big_4d119619f49377f7aacc7efe564c3bf890b3c063.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}