import Foundation
let pattern = #"^(http|https):\/\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://images.unsplash.com/photo-1441742917377-57f78ee0e582?q=80&fm=jpg&s=a79e8a2beba8b3a1ad251798a9024d8b
http://stackoverflow.com/questions/10625497/regex-to-check-if-http-or-https-exists-in-the-string
Http://thepaperwall.com/wallpaper.php?view=4d119619f49377f7aacc7efe564c3bf890b3c063
hTTp://thepaperwall.com/wallpapers/girls/big/big_4d119619f49377f7aacc7efe564c3bf890b3c063.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)