$re = '/\bvalue="\K|\G(?!^)[^"]*?\K\s+/m';
$str = '<input name="so and so" id="john doe" value="something something more something" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);