re = /\bvalue="\K|\G(?!^)[^"]*?\K\s+/m
str = '<input name="so and so" id="john doe" value="something something more something" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end