package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\Qtest\E.*$|.*\Qtest\E)$`)
var str = `testsample 2222222
111111 sampletest`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}