$re = '/^(\Qtest\E.*$|.*\Qtest\E)$/m';
$str = 'testsample 2222222
111111 sampletest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);