package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:(?:(?:lorem|ipsum|dolor)\s?)+)`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ipsum lorem dolor Curabitur ac risus nunc. Dolor ipsum lorem.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}