re = /(?:(?:(?:lorem|ipsum|dolor)\s?)+)/i
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ipsum lorem dolor Curabitur ac risus nunc. Dolor ipsum lorem.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end