package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(YOUU|MEIU) \d+ \d\b`)
var str = `MEIU 810851 0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}