re = /(?:\b[A-Z0-9]+$|\b\d+MTX\b)/m
str = 'Please refer to reference MZ5051CLA
or
Attention for Mr Danshi, RE. 11123MTX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end