// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\b[A-Z0-9]+$|\b\d+MTX\b)").unwrap();
let string = "Please refer to reference MZ5051CLA
or
Attention for Mr Danshi, RE. 11123MTX";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}