$re = '/\b[A-Z0-9]+$/m';
$str = 'Please refer to reference MZ5051CLA
or
Attention for Mr Danshi, RE. 11123MTX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);